التخطي إلى المحتوى الرئيسي
pdf?stylesheet=default
Blackboard Help

إنشاء مسرد

يمكن أن تحتوي كل دورة تدريبية على قائمة بالمصطلحات الخاصة بها. حيث يتكون كل إدخال من مصطلح بالإضافةً إلى التعريف المصاحب له. وبإمكانك أنت ومؤسستك التحكم في هذا الأمر في حالة توفر أداة قائمة المصطلحات.

حول إنشاء قائمة مصطلحات

إذا كنت تخطط لإنشاء قائمة مصطلحات ضخمة، فيمكنك تحميل ملف يحتوي على جميع المصطلحات أو معظمها، ثم قم بتحديث قائمة المصطلحات يدويًا بإضافة المزيد من المصطلحات. تعد هذه الطريقة هي الأكثر فاعلية لإنشاء قائمة مصطلحات ضخمة للدورة التدريبية.

تُعد إضافة مصطلحات قائمة المصطلحات الفردية يدويًا أمرًا مفيدًا خاصة لقائمة المصطلحات الموجزة التي تحتوي على مصطلحات قليلة أو لتحديث مصطلحات في قائمة مصطلحات موجودة بالفعل.

حول تحميل ملف قائمة المصطلحات

لإنشاء ملف قائمة مصطلحات للتحميل، اكتب المصطلحات والتعريفات في برنامج لجداول البيانات، مثل Microsoft® Excel®. يجب أن تحتوي الملفات على مصطلح وتعريف واحد في كل سطر، حيث يتم سرد المصطلح في عمود والتعريف في العمود الذي يليه. احفظ الملف بتنسيق CSV (قيم مفصولة بفاصلة).

بدلاً من ذلك، يمكنك استخدام محرر نص بسيط لإنشاء ملف قائمة المصطلحات. بوجود إدخال لكل سطر، استخدم الفاصلة أو علامة الجدولة لفصل المصطلح عن التعريف. ثم احفظ الملف بتنسيق CSV أو TXT.

بعد قيامك بإنشاء ملف قائمة مصطلحات، قم بتحميله باستخدام أداة قائمة المصطلحات. يُصبح لديك الخيار إما بتحديث قائمة مصطلحات موجودة أو استبدالها. بعد تحديث قائمة المصطلحات، يمكنك إجراء المزيد من التحديثات بإضافة المصطلحات يدويًا أو تحميل ملف آخر.

في حالة وجود مصطلحات مكررة في الملف الذي تم تحميله، فستحل محل تلك المصطلحات الموجودة في قائمة المصطلحات.

تنسيق ملف قائمة المصطلحات

يتم فصل كل إدخال بحرف نهاية سطر داخل الملفات بتنسيق CSV، بالإضافة إلى أنه يتم فصل المصطلح والتعريف بفاصلة. على سبيل المثال:

"تفاح"،"فاكهة حمراء."

"بصل"، "نوع من الخضروات."

وبالرغم من أنه ليس من الضروري في كل الأحوال وضع المصطلح والتعريف داخل علامات اقتباس، إلا أن Blackboard يوصي بشدة بهذا الإجراء وذلك لتجنب حدوث خطأ أثناء المعالجة.

 

"تفاح","فاكهة لذيذة، عادة ما يكون لونها <b>أحمر</b>. وتتم زراعة التفاح في جميع أنحاء العالم، وهو رمز ديني وأسطوري مهم في عديد من الحضارات. وتشتهر منطقة شمال غرب المحيط الهادئ في الولايات المتحدة وبالتحديد في ولاية واشنطن بزراعة التفاح.<br><br> وبالرغم من ذلك فإن نخبة محبي التفاح يُجمعون على أن أفضل أنواع التفاح تأتي من وادي نهر هدسون في نيويورك. وربما يكون ذلك هو السبب وراء إطلاق لقب ""التفاحة الكبيرة""" على مدينة نيويورك.

"بصل","البصل هو أحد الخضروات اللذيذة، وله سيقان خضراء تنتهي بثمرة بيضاء أو صفراء أو حمراء. وللحصول على أجود أنواع البصل، تفضل بزيارة \"عاصمة البصل في العالم\" في نيويورك بجزيرة باين."

يجب تجاهل علامات الاقتباس التي تظهر مع تعريف أو مصطلح. وهذا يعني أنه يجب تحديد علامة الاقتباس كجزء من التعريف، وإلا فسوف يتم قراءة العلامة على أنها نهاية التعريف. ويمكن تجاهل علامات الاقتباس عن طريق استخدام خط مائل عكسي (\")، أو باستخدام مجموعة أخرى من علامات الاقتباس ("").

ملفات دُفعية

الملفات الدُفعية هي ملفات بامتداد TXT وتحتوي على قدر كبير من المعلومات المراد تحميلها إلى النظام. تحتوي كل أداة مساعدة للملفات الدفعية على إرشادات معينة حول إنشاء الملف الدُفعي. إن مقاييس الملف الدُفعي التالية مقاييس عالمية.

  • يجب أن تكون جميع الملفات بأحد النوعين المدعمين للملفات: CSV أو TXT.

    يقوم إصدار 2003 لـ Microsoft Excel والإصدارات الأحدث منه بإدراج علامات اقتباس مزدوجة في كل حقل تلقائيًا عند حفظ ورقة العمل على هيئة ملف بتنسيق CSV.

  • يجب أن يكون كل ملف بتنسيق DOS. أما الملفات بتنسيق MAC أو UNIX فيجب تحويلها إلى DOS.
  • يجب وضع الحقول داخل علامات اقتباس مزدوجة. على سبيل المثال: "ENG_201"
  • عند ظهور علامات اقتباس في أحد الحقول، استخدم حرف هروب لتوضيح أن الحرف التالي لا يشير إلى نهاية الحقل. حرف الهروب هو خط مائل عكسي (\). على سبيل المثال: "\"ENG_201\""
  • يجب فصل كل حقل بأحد الفواصل التالية: فاصلة، أو نقطتين، أو علامة جدولة عند تحديد تلقائي، يجب استخدام نوع واحد من الفواصل فقط في كل ملف دُفعي. على سبيل المثال: "ENG_201","أدب إنجليزي" أو " "ENG_201":"أدب إنجليزي"
  • يجب أن يكون كل سجل بسطر منفصل. على سبيل المثال:

    "ENG_201","أدب إنجليزي"

    "ENG_201","أدب إنجليزي"

  • يجب عدم تضمين أسطر فارغة بين السجلات. ستتم معالجة السطر الفارغ مما سيؤدي إلى ظهور خطأ.
  • تُوصي شركة Blackboard بعدم تجاوز عدد السجلات في كل ملف دُفعي 500 سجل نظرًا لقيود نفاد المهلة المقترنة بمعظم المستعرضات.

كيفية تحميل ملف قائمة مصطلحات

  1. يمكنك الوصول إلى قائمة المصطلحات باستخدام الارتباط الافتراضي أدوات من قائمة الدورة التدريبية.

    -أو-

    من لوحة التحكم، قم بتوسيع القسم أدوات الدورة التدريبية، وانقر فوق  قائمة المصطلحات.

  2. من الصفحة قائمة المصطلحات، انقر فوق تحميل قائمة المصطلحات من القائمة المنسدلة
  3. على الصفحة تحميل قائمة المصطلحات، قم بالاستعراض لتحديد موقع الملف.
  4. حدد خيارًا من خيارات حفظ المصطلحات الحالية:
    • إضافة المصطلحات الموجودة في هذا الملف لقائمة المصطلحات: استخدم هذا الخيار لتكملة قائمة المصطلحات الموجودة التي تحتوي على قائمة بالمصطلحات الجديدة. وفي حالة ظهور مصطلح في كل من قائمة المصطلحات الموجودة والملف، فسيحل التعريف الموجود في الملف محل التعريف الموجود في قائمة المصطلحات الموجودة. وفي حالة ظهور نفس المصطلح مرتين أو أكثر في الملف، فسيظهر في قائمة المصطلحات آخر تعريف للمصطلح.
    • حذف كل مصطلحات قائمة المصطلحات واستبدالها بكل مصطلحات هذا الملف: استخدم هذا الخيار لحذف قائمة المصطلحات الموجودة واستبدالها بالمصطلحات الموجودة بالملف.
  5. انقر فوقإرسال.

قم بتغيير وضع التحرير إلى إيقاف تشغيل واعرض قائمة المصطلحات للتأكد من صحة المصطلحات قبل إتاحتها للطلاب.

كيفية إنشاء مصطلح بقائمة المصطلحات

  1. على الصفحة قائمة المصطلحات، انقر فوق إنشاء مصطلح.
  2. من الصفحة إنشاء مصطلح، اكتب المصطلح والتعريف.

    استخدم وظيفة المدقق الإملائي في محرّر المحتوى لفحص الأخطاء الإملائية.

  3. انقر فوقإرسال.

كيفية تنزيل قائمة مصطلحات

يؤدي تنزيل قائمة مصطلحات إلى إنشاء ملف بيانات قيم مفصولة بفاصلة (CSV) من قائمة المصطلحات. ويتم فصل كل إدخال بحرف نهاية سطر بالإضافة إلى أنه يتم فصل المصطلح والتعريف بفاصلة داخل كل إدخال.

يُعد تنزيل قائمة المصطلحات مفيدًا لإضافة مصطلحات إلى دورة تدريبية أخرى. ويمكنك تحرير قائمة المصطلحات دون اتصال ثم تحميله إلى دورة تدريبية أخرى.

يمكنك تحرير قائمة المصطلحات في برنامج جداول بيانات مثل Excel أو في محرر نصوص مثل "المفكرة" ثم تحميله بعد ذلك إلى قائمة المصطلحات. تأكد من الحفاظ على تنسيق الملف كما هو لضمان سهولة التحميل.

  1. على الصفحة قائمة المصطلحات، انقر فوق تنزيل قائمة مصطلحات من القائمة المنسدلة تحميل/تنزيل.
  2. على الصفحة تنزيل قائمة مصطلحات، انقر فوق تنزيل.
  3. في الإطار المنبثق، حدد حفظ باسم وانقر فوق موافق لحفظ ملف قائمة المصطلحات إلى جهاز الكمبيوتر الخاص بك.

كيفية إضافة ارتباط قائمة مصطلحات إلى قائمة الدورة التدريبية

يمكنك إضافة ارتباط إلى قائمة الدورة التدريبية للوصول إلى أداة قائمة المصطلحات بنقرة واحدة. ويمكنك أيضًا تخصيص اسم الارتباط.

  1. قم بتغيير وضع التحرير إلى تشغيل، وأشر إلى علامة الزائد الموجودة أعلى قائمة الدورة التدريبية. تظهر القائمة المنسدلة إضافة عنصر القائمة.
  2. انقر فوق Tool Link (ارتباط الأداة).
  3. اكتب الاسم الخاص بالارتباط.
  4. من القائمة المنسدلة النوع، انقر فوققائمة المصطلحات.
  5. حدد خانة الاختيار متاح للمستخدمين.
  6. انقر فوقإرسال.

يظهر ارتباط الأداة الجديد في آخر قائمة الدورة التدريبية. اضغط على رمز الأسهم واسحبه لنقل الارتباط إلى الموقع الجديد. وقم بالوصول إلى القائمة السياقية للارتباط لإعادة تسميته أو حذفه أو إخفائه عن الطلاب.